summary refs log tree commit diff stats
path: root/system/services/rust-motd/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/services/rust-motd/default.nix')
-rw-r--r--system/services/rust-motd/default.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/system/services/rust-motd/default.nix b/system/services/rust-motd/default.nix
index 21bc1cd..4f65dce 100644
--- a/system/services/rust-motd/default.nix
+++ b/system/services/rust-motd/default.nix
@@ -3,6 +3,15 @@
   pkgs,
   ...
 }: {
+  systemd.services.rust-motd = {
+    path = builtins.attrValues {
+      inherit
+        (pkgs)
+        bash
+        fail2ban # Needed for rust-motd fail2ban integration
+        ;
+    };
+  };
   programs.rust-motd = {
     enable = true;
     enableMotdInSSHD = true;