summary refs log tree commit diff stats
path: root/system/services/opensshd/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/services/opensshd/default.nix')
-rw-r--r--system/services/opensshd/default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/system/services/opensshd/default.nix b/system/services/opensshd/default.nix
new file mode 100644
index 0000000..75c5aef
--- /dev/null
+++ b/system/services/opensshd/default.nix
@@ -0,0 +1,17 @@
+{
+  config,
+  pkg,
+  ...
+}: {
+  services.openssh = {
+    enable = true;
+    passwordAuthentication = false;
+    hostKeys = [
+      {
+        path = "/srv/sshd/ssh_host_ed25519_key";
+        rounds = 1000;
+        type = "ed25519";
+      }
+    ];
+  };
+}