summary refs log tree commit diff stats
path: root/system/services/nix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/services/nix/default.nix')
-rw-r--r--system/services/nix/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/system/services/nix/default.nix b/system/services/nix/default.nix
new file mode 100644
index 0000000..bd562ec
--- /dev/null
+++ b/system/services/nix/default.nix
@@ -0,0 +1,18 @@
+{
+  config,
+  lib,
+  pkgs,
+  ...
+}: {
+  nix = {
+    #    gc = {
+    #      automatic = true;
+    #      dates = "daily";
+    #      options = "--delete-older-than 3";
+    #    };
+    settings = {
+      auto-optimise-store = true;
+      experimental-features = ["nix-command" "flakes"];
+    };
+  };
+}