summary refs log tree commit diff stats
path: root/system/services/nix-sync/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/services/nix-sync/default.nix')
-rw-r--r--system/services/nix-sync/default.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/system/services/nix-sync/default.nix b/system/services/nix-sync/default.nix
index 8c466b8..9826870 100644
--- a/system/services/nix-sync/default.nix
+++ b/system/services/nix-sync/default.nix
@@ -236,12 +236,12 @@ in {
         message = "Your cachePath ('${cfg.cachePath}') ends with a slash ('/'), please use: '${lib.strings.removeSuffix "/" cfg.cachePath}'.";
       }
     ];
+    systemd = {
+      tmpfiles.rules =
+        generatedDirectories;
 
-    systemd.tmpfiles.rules =
-      generatedDirectories;
-
-    systemd.services = services;
-    systemd.timers = timers;
+      inherit services timers;
+    };
     users.users =
       if cfg.user == "nix-sync"
       then {