summary refs log tree commit diff stats
path: root/system/services/nginx/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/services/nginx/default.nix')
-rw-r--r--system/services/nginx/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/system/services/nginx/default.nix b/system/services/nginx/default.nix
new file mode 100644
index 0000000..204783b
--- /dev/null
+++ b/system/services/nginx/default.nix
@@ -0,0 +1,15 @@
+{...}: {
+  networking.firewall = {
+    allowedTCPPorts = [80 443];
+  };
+  services.nginx = {
+    enable = true;
+    virtualHosts = {
+      "vhack.eu" = {
+        forceSSL = true;
+        enableACME = true;
+        root = "/srv/www/vhack.eu";
+      };
+    };
+  };
+}