summary refs log tree commit diff stats
path: root/system/services/mastodon/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/services/mastodon/default.nix')
-rw-r--r--system/services/mastodon/default.nix12
1 files changed, 7 insertions, 5 deletions
diff --git a/system/services/mastodon/default.nix b/system/services/mastodon/default.nix
index 8e2c174..f613bf3 100644
--- a/system/services/mastodon/default.nix
+++ b/system/services/mastodon/default.nix
@@ -4,17 +4,19 @@
   ...
 }: let
   emailAddress = "mastodon@vhack.eu";
+  applyPatches = pkg:
+    pkg.overrideAttrs (attrs: {
+      patches = (attrs.patches or []) ++ [./patches/0001-feat-treewide-Increase-character-limit-to-5000-in-me.patch];
+    });
 in {
   services.mastodon = {
     enable = true;
 
-    package = pkgs.mastodon.overrideAttrs (attrs: {
-      patches = (attrs.patches or []) ++ [./patches/mastodon_v4.2.1-maxchar-5000.patch];
-    });
+    package = applyPatches pkgs.mastodon;
 
     # Unstable Mastodon package, used if
-    #security updates aren't backported.
-    #package = pkgs-unstable.mastodon;
+    # security updates aren't backported.
+    #package = applyPatches pkgs-unstable.mastodon;
 
     localDomain = "vhack.eu";
     smtp = {