summary refs log tree commit diff stats
path: root/system/services/etebase/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/services/etebase/default.nix')
-rw-r--r--system/services/etebase/default.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/system/services/etebase/default.nix b/system/services/etebase/default.nix
new file mode 100644
index 0000000..65cc435
--- /dev/null
+++ b/system/services/etebase/default.nix
@@ -0,0 +1,42 @@
+{config, ...}: {
+  services.etebase-server = {
+    enable = true;
+    port = 8001;
+    settings = {
+      global.secret_file = "${config.age.secrets.etebase-server.path}";
+      allowed_hosts = {
+        allowed_host1 = "etebase.vhack.eu";
+        allowed_host2 = "dav.vhack.eu";
+      };
+    };
+  };
+
+  services.nginx = {
+    enable = true;
+    recommendedTlsSettings = true;
+    recommendedOptimisation = true;
+    recommendedGzipSettings = true;
+    recommendedProxySettings = true;
+
+    virtualHosts = {
+      "etebase.vhack.eu" = {
+        enableACME = true;
+        forceSSL = true;
+
+        locations = {
+          # TODO: Maybe fix permissions to use pregenerated static files which would
+          # improve performance.
+          #"/static" = {
+          #  root = config.services.etebase-server.settings.global.static_root;
+          #};
+          "/" = {
+            proxyPass = "http://127.0.0.1:${builtins.toString config.services.etebase-server.port}";
+          };
+        };
+        serverAliases = [
+          "dav.vhack.eu"
+        ];
+      };
+    };
+  };
+}