summary refs log tree commit diff stats
path: root/system/impermanence/mods/matrix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/impermanence/mods/matrix.nix')
-rw-r--r--system/impermanence/mods/matrix.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/system/impermanence/mods/matrix.nix b/system/impermanence/mods/matrix.nix
new file mode 100644
index 0000000..7f02609
--- /dev/null
+++ b/system/impermanence/mods/matrix.nix
@@ -0,0 +1,13 @@
+{...}: {
+  environment.persistence."/srv".directories = [
+    {
+      directory = "/var/lib/matrix";
+      user = "matrix-synapse";
+      group = "matrix-synapse";
+      mode = "0700";
+    }
+  ];
+  systemd.tmpfiles.rules = [
+    "d /etc/matrix 0755 matrix-synapse matrix-synapse"
+  ];
+}