summary refs log tree commit diff stats
path: root/system/file_system_layouts/impermanence.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/file_system_layouts/impermanence.nix')
-rw-r--r--system/file_system_layouts/impermanence.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/system/file_system_layouts/impermanence.nix b/system/file_system_layouts/impermanence.nix
new file mode 100644
index 0000000..da38791
--- /dev/null
+++ b/system/file_system_layouts/impermanence.nix
@@ -0,0 +1,16 @@
+{...}: {
+  environment.persistence = {
+    "/srv" = {
+      hideMounts = true;
+      directories = [
+        "/etc/nixos"
+        "/var/log"
+        "/var/lib/postgresql"
+        "/var/lib/acme"
+      ];
+      files = [
+        "/etc/machine-id"
+      ];
+    };
+  };
+}