summary refs log tree commit diff stats
path: root/services/rust-motd.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--services/rust-motd.nix49
1 files changed, 27 insertions, 22 deletions
diff --git a/services/rust-motd.nix b/services/rust-motd.nix
index 62b2188..6ff9367 100644
--- a/services/rust-motd.nix
+++ b/services/rust-motd.nix
@@ -1,9 +1,12 @@
-{ config, pkgs, ... }: {
+{
+  config,
+  pkgs,
+  ...
+}: {
   programs.rust-motd = {
     enable = true;
     enableMotdInSSHD = true;
-    refreshInterval =
-      "*:0/5"; # 0/5 means: hour 0 AND all hour wich match (0 + 5 * x) (is the same as: 0, 5, 10, 15, 20)
+    refreshInterval = "*:0/5"; # 0/5 means: hour 0 AND all hour wich match (0 + 5 * x) (is the same as: 0, 5, 10, 15, 20)
     settings = {
       global = {
         progress_full_character = "=";
@@ -14,11 +17,11 @@
       };
 
       banner = {
-      # color = "red"
-      command = "${pkgs.hostname} | ${pkgs.figlet} -f slant";
-      # if you don't want a dependency on figlet, you can generate your
-      # banner however you want, put it in a file, and then use something like:
-      # command = "cat banner.txt"
+        color = "red";
+        command = "${pkgs.hostname}/bin/hostname | ${pkgs.figlet}/bin/figlet -f slant";
+        # if you don't want a dependency on figlet, you can generate your
+        # banner however you want, put it in a file, and then use something like:
+        # command = "cat banner.txt"
       };
 
       # [weather]
@@ -42,30 +45,32 @@
       # [user_service_status]
       # gpg-agent = "gpg-agent"
 
-      ssl_certificates = {
-        # sort_method = "manual"
-        #
-        #    [ssl_certificates.certs]
-        #    CertName1 = "/path/to/cert1.pem"
-        #    CertName2 = "/path/to/cert2.pem"
-      };
+      #s_s_l_certs = {
+      # sort_method = "manual"
+      #
+      #    certs = {
+      #    CertName1 = "/path/to/cert1.pem"
+      #    CertName2 = "/path/to/cert2.pem"
+      # }
+      #};
 
-      # [filesystems]
-      # root = "/"
+      filesystems = {
+        root = "/";
+      };
 
       memory = {
         swap_pos = "beside"; # or "below" or "none"
       };
 
-      fail_2_ban = {
+      fail2_ban = {
         jails = ["sshd"]; #, "anotherjail"]
       };
 
-      # [last_login]
-      # sally = 2
-      # jimmy = 1
+      last_login = {
+      };
 
-      last_run = true;
+      last_run = {
+      };
     };
   };
 }