summary refs log tree commit diff stats
path: root/modules/by-name/re/resolvconf/module.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/by-name/re/resolvconf/module.nix')
-rw-r--r--modules/by-name/re/resolvconf/module.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/modules/by-name/re/resolvconf/module.nix b/modules/by-name/re/resolvconf/module.nix
new file mode 100644
index 0000000..ff99696
--- /dev/null
+++ b/modules/by-name/re/resolvconf/module.nix
@@ -0,0 +1,16 @@
+{
+  config,
+  lib,
+  ...
+}: let
+  cfg = config.vhack.resolvconf;
+in {
+  options.vhack.resolvconf = {
+    # NOTE(@bpeetz): This condition is taken directly from NixOS. <2024-12-25>
+    enable = lib.mkEnableOption "resolvconf" // {default = !(config.environment.etc ? "resolv.conf");};
+  };
+
+  config = lib.mkIf cfg.enable {
+    users.groups.resolvconf.gid = config.vhack.constants.ids.gids.resolvconf;
+  };
+}