summary refs log tree commit diff stats
path: root/modules/by-name/oo/oomd/module.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/by-name/oo/oomd/module.nix')
-rw-r--r--modules/by-name/oo/oomd/module.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/modules/by-name/oo/oomd/module.nix b/modules/by-name/oo/oomd/module.nix
new file mode 100644
index 0000000..3b39236
--- /dev/null
+++ b/modules/by-name/oo/oomd/module.nix
@@ -0,0 +1,19 @@
+{
+  config,
+  lib,
+  ...
+}: let
+  cfg = config.vhack.systemd.oomd;
+in {
+  options.vhack.systemd.oomd = {
+    # NOTE(@bpeetz): Enabled by default, because that is what NixOS also does. <2024-12-25>
+    enable = (lib.mkEnableOption "oomd") // {default = true;};
+  };
+
+  config = lib.mkIf cfg.enable {
+    users = {
+      users.systemd-oom.uid = config.vhack.constants.ids.uids.systemd-oom;
+      groups.systemd-oom.gid = config.vhack.constants.ids.gids.systemd-oom;
+    };
+  };
+}