summary refs log tree commit diff stats
path: root/hosts/server1/hardware.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/server1/hardware.nix')
-rw-r--r--hosts/server1/hardware.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/hosts/server1/hardware.nix b/hosts/server1/hardware.nix
new file mode 100644
index 0000000..9fabafe
--- /dev/null
+++ b/hosts/server1/hardware.nix
@@ -0,0 +1,9 @@
+{modulesPath, ...}: {
+  imports = [
+    (modulesPath + "/profiles/qemu-guest.nix")
+    (modulesPath + "/profiles/headless.nix")
+  ];
+  boot.loader.grub.device = "/dev/vda";
+  boot.initrd.availableKernelModules = ["ata_piix" "uhci_hcd" "virtio_pci" "sr_mod" "virtio_blk"];
+  boot.initrd.kernelModules = [];
+}