summary refs log tree commit diff stats
path: root/hosts/server1/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/server1/configuration.nix')
-rw-r--r--hosts/server1/configuration.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/hosts/server1/configuration.nix b/hosts/server1/configuration.nix
new file mode 100644
index 0000000..6f91fc0
--- /dev/null
+++ b/hosts/server1/configuration.nix
@@ -0,0 +1,20 @@
+{pkgs, ...}: {
+  imports = [
+    ./networking.nix # network configuration that just works
+
+    ../../system/system.nix
+
+    ../../services/services.nix
+  ];
+
+  boot.cleanTmpDir = true;
+  zramSwap.enable = true;
+  networking.hostName = "server1";
+  networking.domain = "vhack.eu";
+
+  system.fileSystemLayouts.mainDisk = "/dev/vda3";
+
+  system.stateVersion = "22.11";
+}
+# vim: ts=2
+