summary refs log tree commit diff stats
path: root/hosts/server1/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/server1/configuration.nix (renamed from configuration.nix)11
1 files changed, 5 insertions, 6 deletions
diff --git a/configuration.nix b/hosts/server1/configuration.nix
index 8fc047a..729ef0f 100644
--- a/configuration.nix
+++ b/hosts/server1/configuration.nix
@@ -1,13 +1,10 @@
 {pkgs, ...}: {
   imports = [
-    ./hardware-configuration.nix
-    ./packages.nix
     ./networking.nix # network configuration that just works
-    ./users.nix
 
-    ./services/minecraft.nix
-    ./services/rust-motd.nix
-    ./services/opensshd.nix
+    ../../system
+
+    ../../services
   ];
 
   boot.cleanTmpDir = true;
@@ -15,6 +12,8 @@
   networking.hostName = "server1";
   networking.domain = "vhack.eu";
 
+  system.fileSystemLayouts.mainDisk = "/dev/vda3";
+
   system.stateVersion = "22.11";
 }
 # vim: ts=2