summary refs log tree commit diff stats
path: root/hosts/by-name/server2/hardware.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/by-name/server2/hardware.nix')
-rw-r--r--hosts/by-name/server2/hardware.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/hosts/by-name/server2/hardware.nix b/hosts/by-name/server2/hardware.nix
new file mode 100644
index 0000000..9abc64c
--- /dev/null
+++ b/hosts/by-name/server2/hardware.nix
@@ -0,0 +1,14 @@
+{modulesPath, ...}: {
+  imports = [
+    (modulesPath + "/profiles/qemu-guest.nix")
+    (modulesPath + "/profiles/headless.nix")
+  ];
+
+  vhack.disko = {
+    enable = true;
+    # FIXME: Find a better way to specify the disk
+    disk = "/dev/vda";
+  };
+  boot.initrd.availableKernelModules = ["ata_piix" "uhci_hcd" "virtio_pci" "sr_mod" "virtio_blk"];
+  boot.initrd.kernelModules = [];
+}