summary refs log tree commit diff stats
path: root/hosts/by-name/server1/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/by-name/server1/configuration.nix')
-rw-r--r--hosts/by-name/server1/configuration.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/hosts/by-name/server1/configuration.nix b/hosts/by-name/server1/configuration.nix
new file mode 100644
index 0000000..c0e76db
--- /dev/null
+++ b/hosts/by-name/server1/configuration.nix
@@ -0,0 +1,36 @@
+{config, ...}: {
+  imports = [
+    ./networking.nix # network configuration that just works
+    ./hardware.nix
+
+    ../../../system
+  ];
+
+  vhack = {
+    back = {
+      enable = true;
+      repositories = {
+        "${config.services.gitolite.dataDir}/vhack.eu/nixos-config.git" = {
+          domain = "issues.vhack.eu";
+          port = 9220;
+        };
+      };
+    };
+    etesync.enable = true;
+    git-server.enable = true;
+    nginx.enable = true;
+    nix-sync.enable = true;
+    openssh.enable = true;
+    peertube.enable = true;
+    postgresql.enable = true;
+    redlib.enable = true;
+    users.enable = true;
+  };
+
+  boot.tmp.cleanOnBoot = true;
+  zramSwap.enable = true;
+  networking.hostName = "server1";
+  networking.domain = "vhack.eu";
+
+  system.stateVersion = "22.11";
+}