summary refs log tree commit diff stats
path: root/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hardware-configuration.nix')
-rw-r--r--hardware-configuration.nix15
1 files changed, 11 insertions, 4 deletions
diff --git a/hardware-configuration.nix b/hardware-configuration.nix
index 19626a7..8495607 100644
--- a/hardware-configuration.nix
+++ b/hardware-configuration.nix
@@ -3,9 +3,16 @@
   boot.loader.grub.device = "/dev/vda";
   boot.initrd.availableKernelModules = ["ata_piix" "uhci_hcd" "xen_blkfront" "vmw_pvscsi"];
   boot.initrd.kernelModules = ["nvme" "btrfs"];
-  fileSystems."/" = {
-    device = "/dev/vda3";
-    fsType = "btrfs";
-    options = ["subvol=nixos-root"];
+  fileSystems = {
+    "/" = {
+      device = "/dev/vda3";
+      fsType = "btrfs";
+      options = ["subvol=nixos-root"];
+    };
+    "/nix" = {
+      device = "/dev/vda3";
+      fsType = "btrfs";
+      options = ["subvol=nix"];
+    };
   };
 }