summary refs log tree commit diff stats
path: root/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hardware-configuration.nix')
-rw-r--r--hardware-configuration.nix35
1 files changed, 0 insertions, 35 deletions
diff --git a/hardware-configuration.nix b/hardware-configuration.nix
deleted file mode 100644
index d960da6..0000000
--- a/hardware-configuration.nix
+++ /dev/null
@@ -1,35 +0,0 @@
-{modulesPath, ...}: {
-  imports = [
-      (modulesPath + "/profiles/qemu-guest.nix")
-      (modulesPath + "/profiles/headless.nix")
-  ];
-  boot.loader.grub.device = "/dev/vda";
-  boot.initrd.availableKernelModules = ["ata_piix" "uhci_hcd" "xen_blkfront" "vmw_pvscsi"];
-  boot.initrd.kernelModules = ["nvme" "btrfs"];
-  fileSystems = {
-    "/" = {
-      device = "tmpfs";
-      fsType = "tmpfs";
-      options = ["defaults" "size=2G" "mode=755"];
-    };
-    "/nix" = {
-      device = "/dev/vda3";
-      fsType = "btrfs";
-      options = ["subvol=nix" "compress-force=zstd"];
-    };
-    "/srv" = {
-      device = "/dev/vda3";
-      fsType = "btrfs";
-      options = ["subvol=storage" "compress-force=zstd"];
-    };
-    "/boot" = {
-      device = "/dev/vda3";
-      options = ["subvol=boot" "compress-force=zstd"];
-    };
-
-    "/etc/nixos" = {
-      device = "/srv/nix-config";
-      options = ["bind"];
-    };
-  };
-}