summary refs log tree commit diff stats
path: root/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hardware-configuration.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/hardware-configuration.nix b/hardware-configuration.nix
new file mode 100644
index 0000000..e8756e4
--- /dev/null
+++ b/hardware-configuration.nix
@@ -0,0 +1,9 @@
+{ modulesPath, ... }:
+{
+  imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
+  boot.loader.grub.device = "/dev/vda";
+  boot.initrd.availableKernelModules = [ "ata_piix" "uhci_hcd" "xen_blkfront" "vmw_pvscsi" ];
+  boot.initrd.kernelModules = [ "nvme" "btrfs" ];
+  fileSystems."/" = { device = "/dev/vda3"; fsType = "ext4"; };
+  
+}