summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index f2f6379..9504c04 100644
--- a/flake.nix
+++ b/flake.nix
@@ -17,7 +17,10 @@
     nixpkgs,
     simple-nixos-mailserver,
     ...
-  } @ attrs: {
+  } @ attrs: let
+    system = "x86_64-linux";
+    pkgs = nixpkgs.legacyPackages.${system};
+  in {
     nixosConfigurations."server1" = nixpkgs.lib.nixosSystem {
       system = "x86_64-linux";
       specialArgs = attrs;
@@ -29,5 +32,10 @@
         }
       ];
     };
+    devShells."${system}" = {
+      default = pkgs.mkShell {
+        packages = with pkgs; [nil alejandra statix shellcheck ltex-ls];
+      };
+    };
   };
 }