summary refs log tree commit diff stats
path: root/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/configuration.nix b/configuration.nix
index 600201d..baf982a 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -3,7 +3,9 @@
     ./hardware-configuration.nix
     ./packages.nix
     ./networking.nix # network configuration that just works
+    ./users.nix
     ./services/minecraft.nix
+
   ];
 
   boot.cleanTmpDir = true;
@@ -17,10 +19,6 @@
     passwordAuthentication = false;
     extraConfig = "PrintMotd yes\n"; # this could be done with pam
   };
-  users.users.root.openssh.authorizedKeys.keys = [
-    "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIGBFuTNNn71Rhfnop2cdz3r/RhWWlCePnSBOhTBbu2ME soispha"
-    "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIG63gxw8JePmrC8Fni0pLV4TnPBhCPmSV9FYEdva+6s7 sils"
-  ];
 
   system.stateVersion = "22.11";
 }