summary refs log tree commit diff stats
path: root/users.nix
diff options
context:
space:
mode:
authorsils <sils@sils.li>2023-01-23 21:12:50 +0100
committersils <sils@sils.li>2023-01-23 21:12:50 +0100
commit1b5e27311adf4da0bcfaa15acfbc5005584569e5 (patch)
tree82a4ae678333272b380942f2966f0c71c5881f5a /users.nix
parentMerge pull request 'Remove ssh from the config file and make it's keys persis... (diff)
parentUpdate: Save hashed password for sils (diff)
downloadnixos-server-1b5e27311adf4da0bcfaa15acfbc5005584569e5.tar.gz
nixos-server-1b5e27311adf4da0bcfaa15acfbc5005584569e5.zip
Merge pull request 'User Configuration' (#12) from server1_users into server1
Reviewed-on: https://git.sils.li/vhack.eu/nixos-server/pulls/12
Reviewed-by: sils <sils@sils.li>
Diffstat (limited to 'users.nix')
-rw-r--r--users.nix59
1 files changed, 59 insertions, 0 deletions
diff --git a/users.nix b/users.nix
new file mode 100644
index 0000000..34e1648
--- /dev/null
+++ b/users.nix
@@ -0,0 +1,59 @@
+{pkgs, ...}: {
+  users.mutableUsers = false;
+  users.defaultUserShell = pkgs.zsh;
+
+  users.users = {
+    root = {
+      #uid = 0;
+      #initialHashedPassword = null; # to lock root
+      # Backup, if something happens. TODO remove this later
+      openssh.authorizedKeys.keys = [
+        "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIG63gxw8JePmrC8Fni0pLV4TnPBhCPmSV9FYEdva+6s7 sils"
+        "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIGBFuTNNn71Rhfnop2cdz3r/RhWWlCePnSBOhTBbu2ME soispha"
+      ];
+    };
+
+    sils = {
+      name = "sils";
+      isNormalUser = true;
+      home = "/srv/home/sils";
+      initialHashedPassword = "$y$jFT$KpFnahVCE9JbE.5P3us8o.$ZzSxCusWqe3sL7b6DLgOXNNUf114tiiptM6T8lDxtKC"; # TODO CHANGE
+      uid = 1000;
+      extraGroups = [
+        "wheel"
+      ];
+      openssh.authorizedKeys.keys = [
+        "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIG63gxw8JePmrC8Fni0pLV4TnPBhCPmSV9FYEdva+6s7 sils"
+      ];
+    };
+
+    soispha = {
+      name = "soispha";
+      isNormalUser = true;
+      home = "/srv/home/soispha";
+      initialHashedPassword = "$y$jFT$3.8XmUyukZvpExMUxDZkI.$IVrJgm8ysNDF/0vDD2kF6w73ozXgr1LMVRNN4Bq7pv1";
+      uid = 1001;
+      extraGroups = [
+        "wheel"
+      ];
+      openssh.authorizedKeys.keys = [
+        "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIGBFuTNNn71Rhfnop2cdz3r/RhWWlCePnSBOhTBbu2ME soispha"
+      ];
+    };
+
+    nightingale = {
+      name = "nightingale";
+      isNormalUser = true;
+      home = "/srv/home/nightingale";
+      initialHashedPassword = null; # TODO CHANGE
+      uid = 1002;
+      extraGroups = [
+        "wheel"
+      ];
+      openssh.authorizedKeys.keys = [
+      ];
+    };
+  };
+}
+# vim: ts=2
+