summary refs log tree commit diff stats
path: root/system/system.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-05 08:58:11 +0100
committerene <ene@sils.li>2023-02-05 09:02:27 +0100
commitcb69f4ae60e2d94039a7bb0b5caa566a9d288686 (patch)
treea428bba3e57539142ac96eeeabbe57af2418055f /system/system.nix
parentFlake: Changed the configuration to a flake (diff)
downloadnixos-server-cb69f4ae60e2d94039a7bb0b5caa566a9d288686.tar.gz
nixos-server-cb69f4ae60e2d94039a7bb0b5caa566a9d288686.zip
Fix: correct host name and convenience changes
We used the domain name instead of the host name, which obviously
doesn't work for multiple host. In addition to that I changed some
directory to make importing easier and enabled the "nix-command" and
"flakes" experimental options, to make the `nix flake check` command
usable.

Refs: #15
Diffstat (limited to 'system/system.nix')
-rw-r--r--system/system.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/system/system.nix b/system/system.nix
new file mode 100644
index 0000000..2af4982
--- /dev/null
+++ b/system/system.nix
@@ -0,0 +1,8 @@
+{config, ...}: {
+  imports = [
+    ./system/fileSystemLayouts.nix
+    ./system/hardware.nix
+    ./system/packages.nix
+    ./system/users.nix
+  ];
+}