summary refs log tree commit diff stats
path: root/system/services/opensshd/default.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-03-18 16:21:45 +0100
committerene <ene@sils.li>2023-03-18 16:24:41 +0100
commit5a0cb28f369c104bb371974df876c8c705b0ee7e (patch)
tree0e7f5d56eec9cd6a3b4bc903d920bee418c94f51 /system/services/opensshd/default.nix
parentFix: Try to fix ipv6 (diff)
downloadnixos-server-5a0cb28f369c104bb371974df876c8c705b0ee7e.tar.gz
nixos-server-5a0cb28f369c104bb371974df876c8c705b0ee7e.zip
Refactor: Use better file layout
Diffstat (limited to 'system/services/opensshd/default.nix')
-rw-r--r--system/services/opensshd/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/system/services/opensshd/default.nix b/system/services/opensshd/default.nix
new file mode 100644
index 0000000..cb9f2ba
--- /dev/null
+++ b/system/services/opensshd/default.nix
@@ -0,0 +1,18 @@
+{
+  config,
+  pkg,
+  ...
+}: {
+  services.openssh = {
+    enable = true;
+    passwordAuthentication = false;
+    hostKeys = [
+      {
+        comment = "key comment";
+        path = "/srv/sshd/ssh_host_ed25519_key";
+        rounds = 1000;
+        type = "ed25519";
+      }
+    ];
+  };
+}