summary refs log tree commit diff stats
path: root/system/services/openssh/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-07-03 15:09:12 +0200
committerSoispha <soispha@vhack.eu>2023-07-03 18:31:05 +0200
commit99d4b3b910bff6811b10a91d355e7bcddc956e4c (patch)
tree65b556b0b269271bb6a8c14b6b8c91d4d800c908 /system/services/openssh/default.nix
parentFix(system/services/mail): Tell git-crypt new users.nix location (diff)
downloadnixos-server-99d4b3b910bff6811b10a91d355e7bcddc956e4c.tar.gz
nixos-server-99d4b3b910bff6811b10a91d355e7bcddc956e4c.zip
Fix(system/services/openssh): Rename to 'openssh' as the 'd' is a typo
Diffstat (limited to 'system/services/openssh/default.nix')
-rw-r--r--system/services/openssh/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/system/services/openssh/default.nix b/system/services/openssh/default.nix
new file mode 100644
index 0000000..1bb37ee
--- /dev/null
+++ b/system/services/openssh/default.nix
@@ -0,0 +1,13 @@
+{...}: {
+  services.openssh = {
+    enable = true;
+    settings.PasswordAuthentication = false;
+    hostKeys = [
+      {
+        path = "/srv/sshd/ssh_host_ed25519_key";
+        rounds = 1000;
+        type = "ed25519";
+      }
+    ];
+  };
+}