summary refs log tree commit diff stats
path: root/system/services/nginx/hosts.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-12 19:06:15 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-25 16:43:39 +0200
commit572cb127feab945be51609c75128ba9100deef9f (patch)
tree9737f66611790b793917e9d528f9ed4f3a0e5c4e /system/services/nginx/hosts.nix
parentbuild(flake): update (diff)
downloadnixos-server-572cb127feab945be51609c75128ba9100deef9f.tar.gz
nixos-server-572cb127feab945be51609c75128ba9100deef9f.zip
feat(system/services/nginx): Add the GPG WKD
Diffstat (limited to 'system/services/nginx/hosts.nix')
-rw-r--r--system/services/nginx/hosts.nix26
1 files changed, 25 insertions, 1 deletions
diff --git a/system/services/nginx/hosts.nix b/system/services/nginx/hosts.nix
index 5d27af7..0f6c09e 100644
--- a/system/services/nginx/hosts.nix
+++ b/system/services/nginx/hosts.nix
@@ -1,4 +1,14 @@
-{...}: [
+{...}: let
+  extraWkdSettings = {
+    locations."/.well-known/openpgpkey/hu/".extraConfig = ''
+      default_type application/octet-stream;
+
+      # Came from: https://www.uriports.com/blog/setting-up-openpgp-web-key-directory/
+      # No idea if it is actually necessary
+      # add_header Access-Control-Allow-Origin * always;
+    '';
+  };
+in [
   {
     domain = "vhack.eu";
     root = "/etc/nginx/websites/vhack.eu";
@@ -9,4 +19,18 @@
     root = "/etc/nginx/websites/b-peetz.de";
     url = "https://codeberg.org/bpeetz/b-peetz.de.git";
   }
+
+  # WKD
+  {
+    domain = "openpgpkey.b-peetz.de";
+    root = "/etc/nginx/websites/openpgpkey.b-peetz.de";
+    url = "https://codeberg.org/vhack.eu/gpg_wkd.git";
+    extraSettings = extraWkdSettings;
+  }
+  {
+    domain = "openpgpkey.vhack.eu";
+    root = "/etc/nginx/websites/openpgpkey.vhack.eu";
+    url = "https://codeberg.org/vhack.eu/gpg_wkd.git";
+    extraSettings = extraWkdSettings;
+  }
 ]