summary refs log tree commit diff stats
path: root/system/services/nginx/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-06-17 21:10:57 +0200
committerSoispha <soispha@vhack.eu>2023-06-17 22:03:28 +0200
commitd4b710d0ce3e6e1642e7658971da62c3a1476236 (patch)
tree3eb854dc2df2fced52cf5b8657321f0c459ed823 /system/services/nginx/default.nix
parentFeat(system/services/git-sync): Add (diff)
downloadnixos-server-d4b710d0ce3e6e1642e7658971da62c3a1476236.tar.gz
nixos-server-d4b710d0ce3e6e1642e7658971da62c3a1476236.zip
Fix(system/services/nginx): Switch to git-sync
Diffstat (limited to 'system/services/nginx/default.nix')
-rw-r--r--system/services/nginx/default.nix12
1 files changed, 4 insertions, 8 deletions
diff --git a/system/services/nginx/default.nix b/system/services/nginx/default.nix
index 406f2a1..6753fb0 100644
--- a/system/services/nginx/default.nix
+++ b/system/services/nginx/default.nix
@@ -1,15 +1,11 @@
-{websites, ...}: {
+{...}: {
+  imports = [
+    ./hosts.nix
+  ];
   networking.firewall = {
     allowedTCPPorts = [80 443];
   };
   services.nginx = {
     enable = true;
-    virtualHosts = {
-      "vhack.eu" = {
-        forceSSL = true;
-        enableACME = true;
-        root = "${websites}/websites/vhack.eu";
-      };
-    };
   };
 }