summary refs log tree commit diff stats
path: root/system/services/murmur/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-10-03 17:11:46 +0200
committerSoispha <soispha@vhack.eu>2023-10-03 18:08:39 +0200
commita3c31664dad17674721b0d31eec8ca0d8e57bd3e (patch)
treecc896c0d8716f24427a11bf628715467a5ff7c9c /system/services/murmur/default.nix
parentbuild(flake): update (diff)
downloadnixos-server-a3c31664dad17674721b0d31eec8ca0d8e57bd3e.tar.gz
nixos-server-a3c31664dad17674721b0d31eec8ca0d8e57bd3e.zip
feat(system/services/murmur): Initialize
Diffstat (limited to 'system/services/murmur/default.nix')
-rw-r--r--system/services/murmur/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/system/services/murmur/default.nix b/system/services/murmur/default.nix
new file mode 100644
index 0000000..9c04db0
--- /dev/null
+++ b/system/services/murmur/default.nix
@@ -0,0 +1,23 @@
+{config, ...}: {
+  services.murmur = {
+    enable = true;
+    openFirewall = true;
+    welcometext = ''
+      <b>You never get a second chance to make a first impression</b>
+
+      The entire team of [name of the company] is thrilled to welcome you on board. We hope you’ll do some amazing work here!
+    '';
+    sslKey = "${config.security.acme.certs.murmur.directory}/key.pem";
+    sslCert = "${config.security.acme.certs.murmur.directory}/fullchain.pem";
+
+    registerUrl = "vhack.eu";
+    registerName = "vhack";
+    registerHostname = "mumble.vhack.eu";
+    hostName = "mumble.vhack.eu";
+    clientCertRequired = true;
+  };
+
+  security.acme.certs.murmur = {
+    domain = "mumble.vhack.eu";
+  };
+}