summary refs log tree commit diff stats
path: root/system/services/matrix/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-07-22 17:27:16 +0200
committerSoispha <soispha@vhack.eu>2023-07-22 17:27:16 +0200
commit091af41314b3f6a14c1e8678931e4b97c66e8c8b (patch)
tree26d699718045fa96ded5969d27a10afe463119db /system/services/matrix/default.nix
parentFeat(system): Add matrix-synapse (diff)
downloadnixos-server-091af41314b3f6a14c1e8678931e4b97c66e8c8b.tar.gz
nixos-server-091af41314b3f6a14c1e8678931e4b97c66e8c8b.zip
Fix(system/services/matrix): Fix extra " =" in locations path
Diffstat (limited to 'system/services/matrix/default.nix')
-rw-r--r--system/services/matrix/default.nix13
1 files changed, 5 insertions, 8 deletions
diff --git a/system/services/matrix/default.nix b/system/services/matrix/default.nix
index e35c129..a088159 100644
--- a/system/services/matrix/default.nix
+++ b/system/services/matrix/default.nix
@@ -1,9 +1,4 @@
-{
-  pkgs,
-  lib,
-  config,
-  ...
-}: let
+{pkgs, ...}: let
   fqdn = "matrix.vhack.eu";
   clientConfig."m.homeserver".base_url = "https://${fqdn}";
   serverConfig."m.server" = "${fqdn}:443";
@@ -34,8 +29,10 @@ in {
       "vhack.eu" = {
         enableACME = true;
         forceSSL = true;
-        locations."= /.well-known/matrix/server".extraConfig = mkWellKnown serverConfig;
-        locations."= /.well-known/matrix/client".extraConfig = mkWellKnown clientConfig;
+        locations = {
+          "/.well-known/matrix/server".extraConfig = mkWellKnown serverConfig;
+          "/.well-known/matrix/client".extraConfig = mkWellKnown clientConfig;
+        };
       };
       "matrix.vhack.eu" = {
         enableACME = true;