summary refs log tree commit diff stats
path: root/system/packages.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-04 21:37:52 +0100
committerene <ene@sils.li>2023-02-04 21:44:35 +0100
commitcdbd9f7f83099a48bfa59a886b6e51790d898a24 (patch)
treecffd2aede95072613ba407734995321387ade392 /system/packages.nix
parentFeat: Imported the headless profile (diff)
downloadnixos-server-cdbd9f7f83099a48bfa59a886b6e51790d898a24.tar.gz
nixos-server-cdbd9f7f83099a48bfa59a886b6e51790d898a24.zip
Flake: Changed the configuration to a flake
Nix flakes make a lot of things very easy.
Diffstat (limited to 'system/packages.nix')
-rw-r--r--system/packages.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/system/packages.nix b/system/packages.nix
new file mode 100644
index 0000000..4d33c6e
--- /dev/null
+++ b/system/packages.nix
@@ -0,0 +1,9 @@
+{pkgs, ...}: {
+  environment.systemPackages = with pkgs; [
+    jre_minimal
+    git
+    zsh
+    neovim
+    btrfs-progs
+  ];
+}