summary refs log tree commit diff stats
path: root/system/file_system_layouts/default.nix
diff options
context:
space:
mode:
authorsils <sils@sils.li>2023-04-11 10:55:18 +0200
committersils <sils@sils.li>2023-04-11 10:55:18 +0200
commit5a6dd9797b67c08d58236956fbb43b7fe57f5730 (patch)
tree27418564bc75d03c66c0e5cf5209f0b66e625998 /system/file_system_layouts/default.nix
parentFix(services): Remove Minecraft (diff)
parentChore(flake): Update (diff)
downloadnixos-server-5a6dd9797b67c08d58236956fbb43b7fe57f5730.tar.gz
nixos-server-5a6dd9797b67c08d58236956fbb43b7fe57f5730.zip
Merge pull request 'server1_develop' (#22) from server1_develop into server1
Reviewed-on: https://git.sils.li/vhack.eu/nixos-server/pulls/22
Reviewed-by: sils <sils@sils.li>
Diffstat (limited to 'system/file_system_layouts/default.nix')
-rw-r--r--system/file_system_layouts/default.nix49
1 files changed, 49 insertions, 0 deletions
diff --git a/system/file_system_layouts/default.nix b/system/file_system_layouts/default.nix
new file mode 100644
index 0000000..31b0b0b
--- /dev/null
+++ b/system/file_system_layouts/default.nix
@@ -0,0 +1,49 @@
+{
+  modulesPath,
+  config,
+  lib,
+  ...
+}:
+with lib; let
+  cfg = config.system.fileSystemLayouts;
+in {
+  options.system.fileSystemLayouts = {
+    mainDisk = mkOption {
+      type = lib.types.path;
+      example = literalExpression "/dev/disk/by-uuid/0442cb6d-f13a-4635-b487-fa76189774c5";
+      description = lib.mdDoc "Path to the main disk";
+    };
+  };
+  config = {
+    fileSystems = {
+      "/" = {
+        device = "tmpfs";
+        fsType = "tmpfs";
+        options = ["defaults" "size=2G" "mode=755"];
+      };
+      "/nix" = {
+        device = cfg.mainDisk;
+        fsType = "btrfs";
+        options = ["subvol=nix" "compress-force=zstd"];
+      };
+      "/srv" = {
+        device = cfg.mainDisk;
+        fsType = "btrfs";
+        options = ["subvol=storage" "compress-force=zstd"];
+      };
+      "/boot" = {
+        device = cfg.mainDisk;
+        options = ["subvol=boot" "compress-force=zstd"];
+      };
+
+      "/etc/nixos" = {
+        device = "/srv/nix-config";
+        options = ["bind"];
+      };
+      "/var/lib/acme" = {
+        device = "/srv/acme";
+        options = ["bind"];
+      };
+    };
+  };
+}