summary refs log tree commit diff stats
path: root/system/file_system_layouts/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-07-07 08:06:27 +0200
committerSoispha <soispha@vhack.eu>2023-07-07 08:06:27 +0200
commit0cc2b1da5353721815e34b4b76664b9c80452abb (patch)
treef5a82cdc027768023e66aa31a61c2bf832a0b313 /system/file_system_layouts/default.nix
parentchore(version): v0.2.0 (diff)
parentRefactor(system/impermanence): Move to own directory (diff)
downloadnixos-server-0cc2b1da5353721815e34b4b76664b9c80452abb.tar.gz
nixos-server-0cc2b1da5353721815e34b4b76664b9c80452abb.zip
Merge branch 'disko'
Diffstat (limited to 'system/file_system_layouts/default.nix')
-rw-r--r--system/file_system_layouts/default.nix40
1 files changed, 0 insertions, 40 deletions
diff --git a/system/file_system_layouts/default.nix b/system/file_system_layouts/default.nix
deleted file mode 100644
index 95400bd..0000000
--- a/system/file_system_layouts/default.nix
+++ /dev/null
@@ -1,40 +0,0 @@
-{
-  config,
-  lib,
-  ...
-}:
-with lib; let
-  cfg = config.system.fileSystemLayouts;
-in {
-  options.system.fileSystemLayouts = {
-    mainDisk = mkOption {
-      type = lib.types.path;
-      example = literalExpression "/dev/disk/by-uuid/0442cb6d-f13a-4635-b487-fa76189774c5";
-      description = lib.mdDoc "Path to the main disk";
-    };
-  };
-  config = {
-    fileSystems = {
-      "/" = {
-        device = "tmpfs";
-        fsType = "tmpfs";
-        options = ["defaults" "size=2G" "mode=755"];
-      };
-      "/nix" = {
-        device = cfg.mainDisk;
-        fsType = "btrfs";
-        options = ["subvol=nix" "compress-force=zstd"];
-      };
-      "/srv" = {
-        device = cfg.mainDisk;
-        fsType = "btrfs";
-        options = ["subvol=storage" "compress-force=zstd"];
-        neededForBoot = true;
-      };
-      "/boot" = {
-        device = cfg.mainDisk;
-        options = ["subvol=boot" "compress-force=zstd"];
-      };
-    };
-  };
-}