summary refs log tree commit diff stats
path: root/system/fileSystemLayouts.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-04 21:37:52 +0100
committerene <ene@sils.li>2023-02-04 21:44:35 +0100
commitcdbd9f7f83099a48bfa59a886b6e51790d898a24 (patch)
treecffd2aede95072613ba407734995321387ade392 /system/fileSystemLayouts.nix
parentFeat: Imported the headless profile (diff)
downloadnixos-server-cdbd9f7f83099a48bfa59a886b6e51790d898a24.tar.gz
nixos-server-cdbd9f7f83099a48bfa59a886b6e51790d898a24.zip
Flake: Changed the configuration to a flake
Nix flakes make a lot of things very easy.
Diffstat (limited to 'system/fileSystemLayouts.nix')
-rw-r--r--system/fileSystemLayouts.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/system/fileSystemLayouts.nix b/system/fileSystemLayouts.nix
new file mode 100644
index 0000000..9d03a05
--- /dev/null
+++ b/system/fileSystemLayouts.nix
@@ -0,0 +1,45 @@
+{
+  modulesPath,
+  config,
+  lib,
+  ...
+}:
+with lib; let
+  cfg = config.system.fileSystemLayouts;
+in {
+  options.system.fileSystemLayouts = {
+    mainDisk = mkOption {
+      type = lib.types.path;
+      example = literalExpression "/dev/disk/by-uuid/0442cb6d-f13a-4635-b487-fa76189774c5";
+      description = lib.mdDoc "Path to the main disk";
+    };
+  };
+  config = {
+    fileSystems = {
+      "/" = {
+        device = "tmpfs";
+        fsType = "tmpfs";
+        options = ["defaults" "size=2G" "mode=755"];
+      };
+      "/nix" = {
+        device = cfg.mainDisk;
+        fsType = "btrfs";
+        options = ["subvol=nix" "compress-force=zstd"];
+      };
+      "/srv" = {
+        device = cfg.mainDisk;
+        fsType = "btrfs";
+        options = ["subvol=storage" "compress-force=zstd"];
+      };
+      "/boot" = {
+        device = cfg.mainDisk;
+        options = ["subvol=boot" "compress-force=zstd"];
+      };
+
+      "/etc/nixos" = {
+        device = "/srv/nix-config";
+        options = ["bind"];
+      };
+    };
+  };
+}