summary refs log tree commit diff stats
path: root/system/disks/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-07-07 08:06:27 +0200
committerSoispha <soispha@vhack.eu>2023-07-07 08:06:27 +0200
commit0cc2b1da5353721815e34b4b76664b9c80452abb (patch)
treef5a82cdc027768023e66aa31a61c2bf832a0b313 /system/disks/default.nix
parentchore(version): v0.2.0 (diff)
parentRefactor(system/impermanence): Move to own directory (diff)
downloadnixos-server-0cc2b1da5353721815e34b4b76664b9c80452abb.tar.gz
nixos-server-0cc2b1da5353721815e34b4b76664b9c80452abb.zip
Merge branch 'disko'
Diffstat (limited to '')
-rw-r--r--system/disks/default.nix64
1 files changed, 64 insertions, 0 deletions
diff --git a/system/disks/default.nix b/system/disks/default.nix
new file mode 100644
index 0000000..24898fe
--- /dev/null
+++ b/system/disks/default.nix
@@ -0,0 +1,64 @@
+{
+  config,
+  lib,
+  ...
+}:
+with lib; let
+  cfg = config.system.disks;
+  defaultMountOptions = ["compress-force=zstd:15"];
+in {
+
+  options.system.disks = {
+    disk = mkOption {
+      type = lib.types.path;
+      example = literalExpression "/dev/disk/by-id/ata-WDC_WD10SDRW-11A0XS0_WD-WXP2A901KJN5";
+      description = lib.mdDoc "Path to the disk";
+    };
+  };
+
+  config = {
+    disko.devices = {
+      disk.main = {
+        device = cfg.disk;
+        content = {
+          type = "btrfs";
+          extraArgs = ["-f" "--label nixos"]; # f: Override existing partitions
+          subvolumes = {
+            "nix" = {
+              mountpoint = "/nix";
+              mountOptions = defaultMountOptions;
+            };
+            "persistent-storage" = {
+              mountpoint = "/srv";
+              mountOptions = defaultMountOptions;
+            };
+            "persistent-storage@snapshots" = {
+              mountpoint = "/srv/.snapshots";
+              mountOptions = defaultMountOptions;
+            };
+            "boot" = {
+              mountpoint = "/boot";
+              mountOptions = defaultMountOptions;
+            };
+          };
+        };
+      };
+      nodev = {
+        "/" = {
+          fsType = "tmpfs";
+          mountOptions = ["defaults" "size=2G" "mode=755"];
+        };
+      };
+    };
+    fileSystems = {
+      "/srv" = {
+        neededForBoot = true;
+      };
+      "/boot" = {
+        neededForBoot = true;
+      };
+    };
+  };
+}
+# vim: ts=2
+