summary refs log tree commit diff stats
path: root/services/services.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-05 08:58:11 +0100
committerene <ene@sils.li>2023-02-05 09:02:27 +0100
commitcb69f4ae60e2d94039a7bb0b5caa566a9d288686 (patch)
treea428bba3e57539142ac96eeeabbe57af2418055f /services/services.nix
parentFlake: Changed the configuration to a flake (diff)
downloadnixos-server-cb69f4ae60e2d94039a7bb0b5caa566a9d288686.tar.gz
nixos-server-cb69f4ae60e2d94039a7bb0b5caa566a9d288686.zip
Fix: correct host name and convenience changes
We used the domain name instead of the host name, which obviously
doesn't work for multiple host. In addition to that I changed some
directory to make importing easier and enabled the "nix-command" and
"flakes" experimental options, to make the `nix flake check` command
usable.

Refs: #15
Diffstat (limited to 'services/services.nix')
-rw-r--r--services/services.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/services/services.nix b/services/services.nix
new file mode 100644
index 0000000..6983529
--- /dev/null
+++ b/services/services.nix
@@ -0,0 +1,8 @@
+{config, ...}: {
+  imports = [
+    ./services/minecraft.nix
+    ./services/nix.nix
+    ./services/opensshd.nix
+    ./services/rust-motd.nix
+  ];
+}