summary refs log tree commit diff stats
path: root/services/rust-motd.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-05 08:58:11 +0100
committerene <ene@sils.li>2023-02-05 09:02:27 +0100
commitcb69f4ae60e2d94039a7bb0b5caa566a9d288686 (patch)
treea428bba3e57539142ac96eeeabbe57af2418055f /services/rust-motd.nix
parentFlake: Changed the configuration to a flake (diff)
downloadnixos-server-cb69f4ae60e2d94039a7bb0b5caa566a9d288686.tar.gz
nixos-server-cb69f4ae60e2d94039a7bb0b5caa566a9d288686.zip
Fix: correct host name and convenience changes
We used the domain name instead of the host name, which obviously
doesn't work for multiple host. In addition to that I changed some
directory to make importing easier and enabled the "nix-command" and
"flakes" experimental options, to make the `nix flake check` command
usable.

Refs: #15
Diffstat (limited to 'services/rust-motd.nix')
-rw-r--r--services/rust-motd.nix79
1 files changed, 0 insertions, 79 deletions
diff --git a/services/rust-motd.nix b/services/rust-motd.nix
deleted file mode 100644
index 21bc1cd..0000000
--- a/services/rust-motd.nix
+++ /dev/null
@@ -1,79 +0,0 @@
-{
-  config,
-  pkgs,
-  ...
-}: {
-  programs.rust-motd = {
-    enable = true;
-    enableMotdInSSHD = true;
-    refreshInterval = "*:0/5"; # 0/5 means: hour 0 AND all hour wich match (0 + 5 * x) (is the same as: 0, 5, 10, 15, 20)
-    settings = {
-      global = {
-        progress_full_character = "=";
-        progress_empty_character = "-";
-        progress_prefix = "[";
-        progress_suffix = "]";
-        time_format = "%Y-%m-%d %H:%M:%S";
-      };
-
-      banner = {
-        color = "red";
-        command = "${pkgs.hostname}/bin/hostname | ${pkgs.figlet}/bin/figlet -f slant";
-        # if you don't want a dependency on figlet, you can generate your
-        # banner however you want, put it in a file, and then use something like:
-        # command = "cat banner.txt"
-      };
-
-      # [weather]
-      # url = "https://wttr.in/New+York,New+York?0"
-      # proxy = "http://proxy:8080"
-
-      # [service_status]
-      # Accounts = "accounts-daemon"
-      # Cron = "cron"
-
-      # [docker_status]
-      # Local containers MUST start with a slash
-      # https://github.com/moby/moby/issues/6705
-      #"/nextcloud-nextcloud-1" = "Nextcloud"
-      #"/nextcloud-nextcloud-mariadb-1" = "Nextcloud Database"
-
-      uptime = {
-        prefix = "Uptime:";
-      };
-
-      # [user_service_status]
-      # gpg-agent = "gpg-agent"
-
-      #s_s_l_certs = {
-      # sort_method = "manual"
-      #
-      #    certs = {
-      #    CertName1 = "/path/to/cert1.pem"
-      #    CertName2 = "/path/to/cert2.pem"
-      # }
-      #};
-
-      filesystems = {
-        root = "/";
-      };
-
-      memory = {
-        swap_pos = "beside"; # or "below" or "none"
-      };
-
-      fail2_ban = {
-        jails = ["sshd"]; #, "anotherjail"]
-      };
-
-      last_login = {
-        sils = 2;
-        soispha = 2;
-        nightingale = 2;
-      };
-
-      last_run = {
-      };
-    };
-  };
-}