summary refs log tree commit diff stats
path: root/networking.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-01-07 20:43:57 +0100
committerene <ene@sils.li>2023-01-07 20:43:57 +0100
commit4b2b808224d4c4f249d0367ee2c8f68b825639e5 (patch)
tree0ef566168f19c7677240423e744e6b652e6b1f84 /networking.nix
parentsome people lose keys (diff)
downloadnixos-server-4b2b808224d4c4f249d0367ee2c8f68b825639e5.tar.gz
nixos-server-4b2b808224d4c4f249d0367ee2c8f68b825639e5.zip
Format: First formatting with Alejandra
This marks the beginning of a clean git commit history.
This is because of two changes:
 * Usage of conventional-commits (https://www.conventionalcommits.org/en/v1.0.0/).
 * Consistent formatting of the code base to reduce diff footprints.

The choice of Alejandra as auto-formatter is obviously not final.
Diffstat (limited to 'networking.nix')
-rw-r--r--networking.nix39
1 files changed, 29 insertions, 10 deletions
diff --git a/networking.nix b/networking.nix
index 9b254e0..26d6719 100644
--- a/networking.nix
+++ b/networking.nix
@@ -1,9 +1,10 @@
-{ lib, ... }: {
+{lib, ...}: {
   # This file was populated at runtime with the networking
   # details gathered from the active system.
   networking = {
-    nameservers = [ "8.8.8.8"
- ];
+    nameservers = [
+      "8.8.8.8"
+    ];
     defaultGateway = "89.58.56.1";
     defaultGateway6 = "fe80::1";
     dhcpcd.enable = false;
@@ -11,20 +12,38 @@
     interfaces = {
       eth0 = {
         ipv4.addresses = [
-          { address="89.58.58.33"; prefixLength=22; }
+          {
+            address = "89.58.58.33";
+            prefixLength = 22;
+          }
         ];
         ipv6.addresses = [
-          { address="2a03:4000:6a:3f3:6422:6dff:fe82:939b"; prefixLength=64; }
-{ address="fe80::6422:6dff:fe82:939b"; prefixLength=64; }
+          {
+            address = "2a03:4000:6a:3f3:6422:6dff:fe82:939b";
+            prefixLength = 64;
+          }
+          {
+            address = "fe80::6422:6dff:fe82:939b";
+            prefixLength = 64;
+          }
+        ];
+        ipv4.routes = [
+          {
+            address = "89.58.56.1";
+            prefixLength = 32;
+          }
+        ];
+        ipv6.routes = [
+          {
+            address = "fe80::1";
+            prefixLength = 128;
+          }
         ];
-        ipv4.routes = [ { address = "89.58.56.1"; prefixLength = 32; } ];
-        ipv6.routes = [ { address = "fe80::1"; prefixLength = 128; } ];
       };
-      
     };
   };
   services.udev.extraRules = ''
     ATTR{address}=="66:22:6d:82:93:9b", NAME="eth0"
-    
+
   '';
 }