summary refs log tree commit diff stats
path: root/networking.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-04 21:37:52 +0100
committerene <ene@sils.li>2023-02-04 21:44:35 +0100
commitcdbd9f7f83099a48bfa59a886b6e51790d898a24 (patch)
treecffd2aede95072613ba407734995321387ade392 /networking.nix
parentFeat: Imported the headless profile (diff)
downloadnixos-server-cdbd9f7f83099a48bfa59a886b6e51790d898a24.tar.gz
nixos-server-cdbd9f7f83099a48bfa59a886b6e51790d898a24.zip
Flake: Changed the configuration to a flake
Nix flakes make a lot of things very easy.
Diffstat (limited to 'networking.nix')
-rw-r--r--networking.nix49
1 files changed, 0 insertions, 49 deletions
diff --git a/networking.nix b/networking.nix
deleted file mode 100644
index 26d6719..0000000
--- a/networking.nix
+++ /dev/null
@@ -1,49 +0,0 @@
-{lib, ...}: {
-  # This file was populated at runtime with the networking
-  # details gathered from the active system.
-  networking = {
-    nameservers = [
-      "8.8.8.8"
-    ];
-    defaultGateway = "89.58.56.1";
-    defaultGateway6 = "fe80::1";
-    dhcpcd.enable = false;
-    usePredictableInterfaceNames = lib.mkForce false;
-    interfaces = {
-      eth0 = {
-        ipv4.addresses = [
-          {
-            address = "89.58.58.33";
-            prefixLength = 22;
-          }
-        ];
-        ipv6.addresses = [
-          {
-            address = "2a03:4000:6a:3f3:6422:6dff:fe82:939b";
-            prefixLength = 64;
-          }
-          {
-            address = "fe80::6422:6dff:fe82:939b";
-            prefixLength = 64;
-          }
-        ];
-        ipv4.routes = [
-          {
-            address = "89.58.56.1";
-            prefixLength = 32;
-          }
-        ];
-        ipv6.routes = [
-          {
-            address = "fe80::1";
-            prefixLength = 128;
-          }
-        ];
-      };
-    };
-  };
-  services.udev.extraRules = ''
-    ATTR{address}=="66:22:6d:82:93:9b", NAME="eth0"
-
-  '';
-}