summary refs log tree commit diff stats
path: root/hosts/server1/configuration.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-05 08:58:11 +0100
committerene <ene@sils.li>2023-02-05 09:02:27 +0100
commitcb69f4ae60e2d94039a7bb0b5caa566a9d288686 (patch)
treea428bba3e57539142ac96eeeabbe57af2418055f /hosts/server1/configuration.nix
parentFlake: Changed the configuration to a flake (diff)
downloadnixos-server-cb69f4ae60e2d94039a7bb0b5caa566a9d288686.tar.gz
nixos-server-cb69f4ae60e2d94039a7bb0b5caa566a9d288686.zip
Fix: correct host name and convenience changes
We used the domain name instead of the host name, which obviously
doesn't work for multiple host. In addition to that I changed some
directory to make importing easier and enabled the "nix-command" and
"flakes" experimental options, to make the `nix flake check` command
usable.

Refs: #15
Diffstat (limited to 'hosts/server1/configuration.nix')
-rw-r--r--hosts/server1/configuration.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/hosts/server1/configuration.nix b/hosts/server1/configuration.nix
new file mode 100644
index 0000000..6f91fc0
--- /dev/null
+++ b/hosts/server1/configuration.nix
@@ -0,0 +1,20 @@
+{pkgs, ...}: {
+  imports = [
+    ./networking.nix # network configuration that just works
+
+    ../../system/system.nix
+
+    ../../services/services.nix
+  ];
+
+  boot.cleanTmpDir = true;
+  zramSwap.enable = true;
+  networking.hostName = "server1";
+  networking.domain = "vhack.eu";
+
+  system.fileSystemLayouts.mainDisk = "/dev/vda3";
+
+  system.stateVersion = "22.11";
+}
+# vim: ts=2
+