summary refs log tree commit diff stats
path: root/hardware-configuration.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-01-07 20:43:57 +0100
committerene <ene@sils.li>2023-01-07 20:43:57 +0100
commit4b2b808224d4c4f249d0367ee2c8f68b825639e5 (patch)
tree0ef566168f19c7677240423e744e6b652e6b1f84 /hardware-configuration.nix
parentsome people lose keys (diff)
downloadnixos-server-4b2b808224d4c4f249d0367ee2c8f68b825639e5.tar.gz
nixos-server-4b2b808224d4c4f249d0367ee2c8f68b825639e5.zip
Format: First formatting with Alejandra
This marks the beginning of a clean git commit history.
This is because of two changes:
 * Usage of conventional-commits (https://www.conventionalcommits.org/en/v1.0.0/).
 * Consistent formatting of the code base to reduce diff footprints.

The choice of Alejandra as auto-formatter is obviously not final.
Diffstat (limited to 'hardware-configuration.nix')
-rw-r--r--hardware-configuration.nix15
1 files changed, 8 insertions, 7 deletions
diff --git a/hardware-configuration.nix b/hardware-configuration.nix
index e8756e4..c4fe39a 100644
--- a/hardware-configuration.nix
+++ b/hardware-configuration.nix
@@ -1,9 +1,10 @@
-{ modulesPath, ... }:
-{
-  imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
+{modulesPath, ...}: {
+  imports = [(modulesPath + "/profiles/qemu-guest.nix")];
   boot.loader.grub.device = "/dev/vda";
-  boot.initrd.availableKernelModules = [ "ata_piix" "uhci_hcd" "xen_blkfront" "vmw_pvscsi" ];
-  boot.initrd.kernelModules = [ "nvme" "btrfs" ];
-  fileSystems."/" = { device = "/dev/vda3"; fsType = "ext4"; };
-  
+  boot.initrd.availableKernelModules = ["ata_piix" "uhci_hcd" "xen_blkfront" "vmw_pvscsi"];
+  boot.initrd.kernelModules = ["nvme" "btrfs"];
+  fileSystems."/" = {
+    device = "/dev/vda3";
+    fsType = "ext4";
+  };
 }