summary refs log tree commit diff stats
path: root/hardware-configuration.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-04 21:37:52 +0100
committerene <ene@sils.li>2023-02-04 21:44:35 +0100
commitcdbd9f7f83099a48bfa59a886b6e51790d898a24 (patch)
treecffd2aede95072613ba407734995321387ade392 /hardware-configuration.nix
parentFeat: Imported the headless profile (diff)
downloadnixos-server-cdbd9f7f83099a48bfa59a886b6e51790d898a24.tar.gz
nixos-server-cdbd9f7f83099a48bfa59a886b6e51790d898a24.zip
Flake: Changed the configuration to a flake
Nix flakes make a lot of things very easy.
Diffstat (limited to 'hardware-configuration.nix')
-rw-r--r--hardware-configuration.nix35
1 files changed, 0 insertions, 35 deletions
diff --git a/hardware-configuration.nix b/hardware-configuration.nix
deleted file mode 100644
index d960da6..0000000
--- a/hardware-configuration.nix
+++ /dev/null
@@ -1,35 +0,0 @@
-{modulesPath, ...}: {
-  imports = [
-      (modulesPath + "/profiles/qemu-guest.nix")
-      (modulesPath + "/profiles/headless.nix")
-  ];
-  boot.loader.grub.device = "/dev/vda";
-  boot.initrd.availableKernelModules = ["ata_piix" "uhci_hcd" "xen_blkfront" "vmw_pvscsi"];
-  boot.initrd.kernelModules = ["nvme" "btrfs"];
-  fileSystems = {
-    "/" = {
-      device = "tmpfs";
-      fsType = "tmpfs";
-      options = ["defaults" "size=2G" "mode=755"];
-    };
-    "/nix" = {
-      device = "/dev/vda3";
-      fsType = "btrfs";
-      options = ["subvol=nix" "compress-force=zstd"];
-    };
-    "/srv" = {
-      device = "/dev/vda3";
-      fsType = "btrfs";
-      options = ["subvol=storage" "compress-force=zstd"];
-    };
-    "/boot" = {
-      device = "/dev/vda3";
-      options = ["subvol=boot" "compress-force=zstd"];
-    };
-
-    "/etc/nixos" = {
-      device = "/srv/nix-config";
-      options = ["bind"];
-    };
-  };
-}