summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-04-19 17:07:49 +0200
committerSoispha <soispha@vhack.eu>2023-04-19 17:07:49 +0200
commita67e54e5b33cd5d78ca0ad937ad245f690f6cdb8 (patch)
tree2544aad727a08550a2645fdf3cd01bf97dbea35d /flake.nix
parentDocs(contributing): Add (diff)
downloadnixos-server-a67e54e5b33cd5d78ca0ad937ad245f690f6cdb8.tar.gz
nixos-server-a67e54e5b33cd5d78ca0ad937ad245f690f6cdb8.zip
Feat(system/services/nginx): Change to declarative websites
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 9504c04..3baed70 100644
--- a/flake.nix
+++ b/flake.nix
@@ -4,18 +4,34 @@
 
   inputs = {
     nixpkgs.url = "github:NixOS/nixpkgs/nixos-22.11-small";
+
+    systems.url = "github:nix-systems/x86_64-linux";
+    flake-utils = {
+      url = "github:numtide/flake-utils";
+      inputs.systems.follows = "systems";
+    };
+
     simple-nixos-mailserver = {
       url = "gitlab:simple-nixos-mailserver/nixos-mailserver/nixos-22.11";
       inputs = {
         nixpkgs.follows = "nixpkgs";
       };
     };
+    websites = {
+      url = "git+https://codeberg.org/vhack.eu/website.git";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+        systems.follows = "systems";
+        flake-utils.follows = "flake-utils";
+      };
+    };
   };
 
   outputs = {
     self,
     nixpkgs,
     simple-nixos-mailserver,
+    websites,
     ...
   } @ attrs: let
     system = "x86_64-linux";