summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorsils <sils@sils.li>2023-04-21 08:00:03 +0200
committersils <sils@sils.li>2023-04-21 08:00:03 +0200
commit50fd32a0cf30ad7b4b4c14a23aa42002e0c55781 (patch)
tree2544aad727a08550a2645fdf3cd01bf97dbea35d /flake.nix
parentMerge pull request 'server1_build' (#25) from server1_build into server1 (diff)
parentFeat(system/services/nginx): Change to declarative websites (diff)
downloadnixos-server-50fd32a0cf30ad7b4b4c14a23aa42002e0c55781.tar.gz
nixos-server-50fd32a0cf30ad7b4b4c14a23aa42002e0c55781.zip
Merge pull request 'Feat(system/services/nginx): Change to declarative websites' (#29) from server1_webpage into develop
Reviewed-on: https://codeberg.org/vhack.eu/nixos-server/pulls/29
Diffstat (limited to '')
-rw-r--r--flake.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 9504c04..3baed70 100644
--- a/flake.nix
+++ b/flake.nix
@@ -4,18 +4,34 @@
 
   inputs = {
     nixpkgs.url = "github:NixOS/nixpkgs/nixos-22.11-small";
+
+    systems.url = "github:nix-systems/x86_64-linux";
+    flake-utils = {
+      url = "github:numtide/flake-utils";
+      inputs.systems.follows = "systems";
+    };
+
     simple-nixos-mailserver = {
       url = "gitlab:simple-nixos-mailserver/nixos-mailserver/nixos-22.11";
       inputs = {
         nixpkgs.follows = "nixpkgs";
       };
     };
+    websites = {
+      url = "git+https://codeberg.org/vhack.eu/website.git";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+        systems.follows = "systems";
+        flake-utils.follows = "flake-utils";
+      };
+    };
   };
 
   outputs = {
     self,
     nixpkgs,
     simple-nixos-mailserver,
+    websites,
     ...
   } @ attrs: let
     system = "x86_64-linux";