summary refs log tree commit diff stats
path: root/configuration.nix
diff options
context:
space:
mode:
authorsils <sils@sils.li>2023-01-08 00:03:49 +0100
committersils <sils@sils.li>2023-01-08 00:03:49 +0100
commit473f5c2a87eb6aecf93fcab873fa16d07e7bcb9e (patch)
tree6745f07b44524b73ece4244e6318bdecdd10da9c /configuration.nix
parentsome people lose keys (diff)
parentFeat: Some security for ssh (diff)
downloadnixos-server-473f5c2a87eb6aecf93fcab873fa16d07e7bcb9e.tar.gz
nixos-server-473f5c2a87eb6aecf93fcab873fa16d07e7bcb9e.zip
Merge pull request 'Format: First formatting with Alejandra' (#2) from ene/nixos-server:server1 into server1
Reviewed-on: https://git.sils.li/vhack.eu/nixos-server/pulls/2
Reviewed-by: sils <sils@sils.li>
Diffstat (limited to '')
-rw-r--r--configuration.nix17
1 files changed, 11 insertions, 6 deletions
diff --git a/configuration.nix b/configuration.nix
index e531a8e..852a6ee 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -1,21 +1,26 @@
-{ pkgs, ... }: {
+{pkgs, ...}: {
   imports = [
     ./hardware-configuration.nix
     ./packages.nix
-    ./networking.nix # generated at runtime by nixos-infect
-    
+    ./networking.nix # network configuration that just works
   ];
 
   boot.cleanTmpDir = true;
   zramSwap.enable = true;
   networking.hostName = "server1";
   networking.domain = "vhack.eu";
-  services.openssh.enable = true;
+
+  # openssh config
+  services.openssh = {
+    enable = true;
+    passwordAuthentication = false;
+    extraConfig = "PrintMotd yes\n"; # this could be done with pam
+  };
   users.users.root.openssh.authorizedKeys.keys = [
-    "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIK2mYuiOuIb13E3wJRYPHOFN/dR5ySFozG2I/18HBSRJ dt@DESKTOP-IDOHVE" 
     "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIGBFuTNNn71Rhfnop2cdz3r/RhWWlCePnSBOhTBbu2ME soispha"
-    "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIG63gxw8JePmrC8Fni0pLV4TnPBhCPmSV9FYEdva+6s7 sils" 
+    "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIG63gxw8JePmrC8Fni0pLV4TnPBhCPmSV9FYEdva+6s7 sils"
   ];
 
   system.stateVersion = "22.11";
 }
+# vim: ts=2