# vim: ts=2
{
  lib,
  config,
  ...
}: let
  cfg = config.soispha.services.steam;
in {
  options.soispha.services.steam = {
    enable = lib.mkOption {
      default = true;
      description = lib.mdDoc "Enable Steam";
    };
  };
  config = lib.mkIf cfg.enable {
    programs.steam = {
      enable = true;
    };
  };
}