# vim: ts=2
{pkgs, ...}: {
  virtualisation = {
    #    cores = 8;
    #    diskSize = 25000;
    #    useEFIBoot = true;
    #    resolution = {
    #      x = 1920;
    #      y = 1080;
    #    };
    #    memorySize = 8024;
    #    sharedDirectories = {}; # TODO add some
    libvirtd = {
      enable = true;
      qemu = {
        package = pkgs.qemu_full;
        ovmf = {
          enable = true;
          packages = [pkgs.OVMFFull.fd];
        };
      };
    };
  };
  users.users.soispha.extraGroups = [
    "libvirtd" # to run libvirt stuff as this user
  ];
}