{lib, ...}: {
  imports = [
    ./boot
    ./disks
    ./font
    ./hardware
    #./impermanence already at flake level imported
    ./libvirtd
    ./locale
    ./network
    #./nixpkgs already at flake level imported
    ./options
    ./polkit
    ./services
    ./sound
    ./tempfiles
    ./users # the position of this item is fully arbitrary
  ];
  # remove all the bloat, which nixos installs by default
  environment = {
    defaultPackages = lib.mkForce [];
  };
}