{
  config,
  lib,
  ...
}: {
  home = {
    activation = {
      addManifestJson =
        lib.hm.dag.entryAfter ["writeBoundary"]
        ''
          [ -L "${config.xdg.stateHome}/nix/profiles/profile" ] && $DRY_RUN_CMD rm $VERBOSE_ARG "${config.xdg.stateHome}/nix/profiles/profile"
          $DRY_RUN_CMD ln -s $DRY_RUN_CMD "${./profile}" "${config.xdg.stateHome}/nix/profiles/profile"
        '';
    };
  };
}