{
  config,
  lib,
  # options
  prefConfig,
  profile_size,
  search,
  userChrome,
  ...
}: let
  inherit (config.soispha.taskwarrior.projects) projects;

  mkFirefoxProfile = {
    name,
    id,
  }: {
    inherit name;
    value = {
      isDefault = false;
      extraConfig = prefConfig;
      inherit id name search userChrome;
    };
  };
  projects_id =
    lib.imap0 (id: project: {
      name = project;
      id = id + profile_size;
    })
    projects;
  firefoxProfiles = builtins.listToAttrs (builtins.map mkFirefoxProfile projects_id);
in
  firefoxProfiles